1.网络或墙的问题导致插件下载安装失败

 
解决方法
为Jenkins更换源
点击Jenkins主页面左侧列表中【系统管理】—— 下拉找到【管理插件】
 
选择【高级】选项卡
替换最下方【升级站点】中的URL
http://updates.jenkins-ci.org/update-center.json
替换为
http://mirror.esuni.jp/jenkins/updates/update-center.json
保存后,即可返回到【可选插件】选项卡下,进行搜索重新安装。
 

2.因为Jenkins版本太低导致插件不支持

可以在线升级Jenkins的版本,即下载war包进行升级。
解决方法:
1.上面所说,因为Jenkins本身版本过低的问题,导致插件安装不成功。可以自行升级Jenkins版本,来解决这个问题。
 
2.但是像这种使用docker镜像启动的,升级Jenkins的版本是没多大戏了,除非你把这个容器和对应镜像干掉。下载更新的镜像来启动Jenkins容器。
 
所以可以通过下载插件历史版本,然后在Jenkins进行上传插件的方式来解决这个问题。也就是所谓的手动下载上传插件安装。

 

自行升级Jenkins版本:

1.一定要在Jenkins官网查找最新版本
2.选择对应操作方式的最新版本,例如:docker安装包   或者  windows安装包或者其他。
 
 
手动下载上传插件安装:
这里就以安装Docker Pipline插件为例,演示手动下载上传插件安装:
1、首先咱们可以在启动的Jenkins上的 系统管理进入
2、可以看到错误日志中 Docker Pipline V1.17版本 所依赖的Pipline GroovyV2.57.2的版本 需要Jenkins版本在2.62以上才可以使用
 
3、同样在Jenkins的系统管理下的 插件管理下 可以看到